IAD customers intermittent connectivity

Incident Report for RapidScale

Resolved

This incident has been resolved, IAD customer connectivity is functioning normally again.
Posted May 01, 2026 - 09:17 EDT

Investigating

IAD customers may experience intermittent connectivity issues. RapidScale teams are engaged to investigate.
Posted Apr 30, 2026 - 15:45 EDT
This incident affected: RapidScale Data Centers (IAD (Virginia data center)).