Talkdesk services degraded

Incident Report for RapidScale

Resolved

The RapidScale phone system service provider issues experienced have been resolved. Please report any continued issues.
Posted Jun 10, 2025 - 12:31 EDT

Identified

The RapidScale phone system service provider is currently experiencing an issue and inbound phone lines are not operational at this time.
Posted Jun 10, 2025 - 11:32 EDT
This incident affected: RapidScale Support (Talkdesk Inbound (Telephony), Talkdesk Outbound (Telephony)).