LAX Data Center Outage

Incident Report for RapidScale

Resolved

The connectivity issues at the LAX data center have been resolved.
Posted Jul 30, 2025 - 03:58 EDT

Investigating

The LAX data center is experiencing connectivity issues. We are investigating the issue and will update once we know more
Posted Jul 29, 2025 - 23:44 EDT
This incident affected: RapidScale Data Centers (SNA (Irvine, CA data center)).