RapidScale Support Phone Systems Unavailable

Incident Report for RapidScale

Resolved

We’ve been able to confirm the incident is fully resolved
Posted Mar 31, 2025 - 14:01 EDT

Monitoring

A fix has been implemented by the phone service provider and we are seeing functionality return. We will leave this in a monitoring state for the next hour, if no issues are identified we will move this incident to resolved.

Thank you!
Posted Mar 31, 2025 - 13:33 EDT

Update

We have identified that our outbound calls are operational, and only inbound calls are non-operational at this time. The vendor has reported outbound instability, we do not seem to be impacted by the aformentioned instability.
Posted Mar 31, 2025 - 13:04 EDT

Investigating

The RapidScale phone system service provider is currently experiencing an issue and phone lines are not operational at this time. To contact support, please navigate to portal.rapidscale.net and open a ticket, or update your existing ticket. You may also leverage our chat system to speak with an agent.

We will continue to update this incident as we have more information.
Posted Mar 31, 2025 - 13:01 EDT
This incident affected: RapidScale Support (Talkdesk Inbound (Telephony), Talkdesk Outbound (Telephony)).