Microsoft reports that service is continuing to incrementally recover. They are forecasting that the impact will be fully remediated by 10pm EST on Monday November 25, 2024.
Posted Nov 25, 2024 - 19:39 EST
Update
Microsoft has identified a change in the environment that resulted in an influx in request retries routed though affected servers. Microsoft is monitoring the service and continuing their work to perform any follow-up actions or opening additional workstreams needed to fully resolve the problem.
Posted Nov 25, 2024 - 17:55 EST
Monitoring
We have identified a Microsoft performance/connectivity issue. The issue, identified as MO941162, began on November 24, 2024, at 6:54 PM PST. Users may experience difficulties accessing or using services such as Exchange Online, Microsoft Teams, SharePoint Online, Microsoft Purview, and others.
The root cause is linked to a recent Microsoft change that affected infrastructure performance. Microsoft's mitigative actions haven't provided relief as expected, and a portion of infrastructure remains in an unhealthy state. Microsoft has determined that some of the targeted server restarts did not succeed due to processing issues, which are under investigation.
Microsoft is currently focused on spreading traffic to healthy infrastructure and apply targeted remediation to impacted servers. Services are showing significant signs of restoration following our infrastructure optimizations to redistribute traffic and restart affected servers, upwards of 90 percent recovery as Microsoft continues to increase processing capability.