Talkdesk Outage

Incident Report for RapidScale

Resolved

Mitigation measures have been implemented by the Talkdesk team and the issues have been resolved.
Posted Sep 05, 2025 - 18:03 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 05, 2025 - 15:45 EDT

Monitoring

We are currently experiencing an outage with Taldesk which is impacting incoming and outgoing calls with Rapidscale. Talkdesk is working to resolve the issue. If you need to open a case, please utilize the Rapidscale Portal for the time being.
Posted Sep 05, 2025 - 15:38 EDT
This incident affected: RapidScale Support (Talkdesk Inbound (Telephony), Talkdesk Outbound (Telephony)).