ORD Data Center Backup Jobs

Incident Report for RapidScale

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 09:32 EDT

Update

This incident has been resolved.
Posted Mar 16, 2026 - 09:26 EDT

Update

We are continuing to investigate this issue.
Posted Mar 16, 2026 - 08:47 EDT

Investigating

We are currently investigating an issue impacting backup job completion for a subset of customers in the ORD datacenter. Our engineering teams are actively working to restore normal service. Further updates will be provided as more information becomes available.
Posted Mar 16, 2026 - 08:45 EDT
This incident affected: RapidScale Data Centers (ORD (Chicago, IL data center)).