Global DUO Outage

Incident Report for RapidScale

Resolved

DUO has identified and corrected the issue. All services have been restored
Posted Feb 13, 2025 - 22:21 EST

Update

RapidScale is currently tracking a global DUO outage impacting authentication through DUO. This is DUOs current response:

"We are seeing successful SMS and Phone Call Delivery for the following deployments below. Other deployments not in the list may still be impacted:

DUO9
DUO17
DUO22
DUO39
DUO40
DUO42
DUO45
DUO49
DUO50
DUO52
DUO55
DUO56
DUO58
DUO62
DUO63
DUO64
DUO65
DUO72
DUO73
DUO74
DUO75
DUO76
DUO77
DUO78

We are still actively working toward restoring all other services and will provide updates as soon as possible"
Posted Feb 13, 2025 - 17:08 EST

Identified

RapidScale is currently tracking a global DUO outage impacting authentication through DUO. This is DUOs current response:

"DUO has identified the issue causing Admin Panel login, Device Management Portal, Risk-based Authentication, and SMS/Phone Call delivery failures across all deployments and are working to deploy a fix.

If you have your Admin Panel URL saved, you can navigate to the URL (ex. admin-xxxxxxxx.duosecurity.com/) to get direct access.

When accessing the Admin Panel, please utilize non-telephony-based MFA methods to ensure proper access. Admin's currently logged in can activate Duo Push for other admins following this documentation: https://duo.com/docs/administration-admins#updating-an-administrator's-secondary-authentication-methods"
Posted Feb 13, 2025 - 14:13 EST

Investigating

RapidScale is currently tracking a global DUO outage impacting authentication through DUO. This is DUOs current response:

"DUO has identified the issue causing Admin Panel login, Device Management Portal, Risk-based Authentication, and SMS/Phone Call delivery failures across all deployments and are working to deploy a fix."
Posted Feb 13, 2025 - 14:12 EST